[binutils-gdb] ld: rename ldirname to stat_ldirname

Andreas Schwab schwab@sourceware.org
Thu May 15 08:22:29 GMT 2025


https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=27ba92a50c7abbfebf9f1fbc539c39f0011d2fd7

commit 27ba92a50c7abbfebf9f1fbc539c39f0011d2fd7
Author: Andreas Schwab <schwab@suse.de>
Date:   Wed May 14 17:09:45 2025 +0200

    ld: rename ldirname to stat_ldirname
    
    It conflicts with the ldirname function that will be added in the next
    libiberty sync.
    
    ld/:
            * ldlang.c (stat_ldirname): Rename from ldirname, all uses
            changed.

Diff:
---
 ld/ldlang.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/ld/ldlang.c b/ld/ldlang.c
index e0368171fa9..32e6e7abdf1 100644
--- a/ld/ldlang.c
+++ b/ld/ldlang.c
@@ -322,7 +322,7 @@ spec_match (const struct wildcard_spec *spec, const char *name)
 }
 
 static char *
-ldirname (const char *name)
+stat_ldirname (const char *name)
 {
   const char *base = lbasename (name);
 
@@ -1266,7 +1266,7 @@ new_afile (const char *name,
       /* If name is a relative path, search the directory of the current linker
 	 script first. */
       if (from_filename && !IS_ABSOLUTE_PATH (name))
-	p->extra_search_path = ldirname (from_filename);
+	p->extra_search_path = stat_ldirname (from_filename);
       p->flags.real = true;
       p->flags.search_dirs = true;
       break;


More information about the Binutils-cvs mailing list