[binutils-gdb] Z8k: use is_end_of_stmt()

Jan Beulich jbeulich@sourceware.org
Fri Mar 7 07:25:58 GMT 2025


https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=02b4b482c3104b14a5df3d4b0228ba56f4a95433

commit 02b4b482c3104b14a5df3d4b0228ba56f4a95433
Author: Jan Beulich <jbeulich@suse.com>
Date:   Fri Mar 7 08:23:37 2025 +0100

    Z8k: use is_end_of_stmt()
    
    ... instead of open-coding it.

Diff:
---
 gas/config/tc-z8k.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/gas/config/tc-z8k.c b/gas/config/tc-z8k.c
index d73df4ffb1e..4cfb302d82c 100644
--- a/gas/config/tc-z8k.c
+++ b/gas/config/tc-z8k.c
@@ -536,7 +536,7 @@ get_interrupt_operand (char **ptr, struct z8k_op *mode, unsigned int dst ATTRIBU
 		  *ptr = src + l;
 		invalid:
 		  as_bad (_("unknown interrupt %s"), src);
-		  while (**ptr && ! is_end_of_line[(unsigned char) **ptr])
+		  while (! is_end_of_stmt (**ptr))
 		    (*ptr)++;	 /* Consume rest of line.  */
 		  return;
 		}
@@ -747,10 +747,10 @@ get_operands (const opcode_entry_type *opcode, char *op_end, op_type *operand)
           get_cc_operand (&ptr, operand + 0, 0);
           while (is_whitespace (*ptr))
             ptr++;
-          if (*ptr && ! is_end_of_line[(unsigned char) *ptr])
+          if (! is_end_of_stmt (*ptr))
             {
               as_bad (_("invalid condition code '%s'"), ptr);
-              while (*ptr && ! is_end_of_line[(unsigned char) *ptr])
+              while (! is_end_of_stmt (*ptr))
                 ptr++;   /* Consume rest of line.  */
             }
         }
@@ -759,10 +759,10 @@ get_operands (const opcode_entry_type *opcode, char *op_end, op_type *operand)
 	  get_flags_operand (&ptr, operand + 0, 0);
 	  while (is_whitespace (*ptr))
 	    ptr++;
-	  if (*ptr && ! is_end_of_line[(unsigned char) *ptr])
+	  if (! is_end_of_stmt (*ptr))
 	    {
 	      as_bad (_("invalid flag '%s'"), ptr);
-	      while (*ptr && ! is_end_of_line[(unsigned char) *ptr])
+	      while (*ptr && ! is_end_of_stmt (*ptr))
 		ptr++;	 /* Consume rest of line.  */
 	    }
 	}


More information about the Binutils-cvs mailing list