[binutils-gdb] SCFI: correct test names
Jan Beulich
jbeulich@sourceware.org
Fri Feb 16 09:20:35 GMT 2024
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=d7360469b621112739e82550c1f9ca639f513c70
commit d7360469b621112739e82550c1f9ca639f513c70
Author: Jan Beulich <jbeulich@suse.com>
Date: Fri Feb 16 10:18:16 2024 +0100
SCFI: correct test names
Having multiple tests with the same name is confusing.
Diff:
---
gas/testsuite/gas/scfi/x86_64/scfi-indirect-mov-4.d | 2 +-
gas/testsuite/gas/scfi/x86_64/scfi-pushsection-2.d | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/gas/testsuite/gas/scfi/x86_64/scfi-indirect-mov-4.d b/gas/testsuite/gas/scfi/x86_64/scfi-indirect-mov-4.d
index 614be3b5dce..44516b9cb13 100644
--- a/gas/testsuite/gas/scfi/x86_64/scfi-indirect-mov-4.d
+++ b/gas/testsuite/gas/scfi/x86_64/scfi-indirect-mov-4.d
@@ -1,7 +1,7 @@
#as: --scfi=experimental -W
#as:
#objdump: -Wf
-#name: Synthesize CFI for indirect mem op to stack 3
+#name: Synthesize CFI for indirect mem op to stack 4
#...
Contents of the .eh_frame section:
diff --git a/gas/testsuite/gas/scfi/x86_64/scfi-pushsection-2.d b/gas/testsuite/gas/scfi/x86_64/scfi-pushsection-2.d
index abddd9dedd6..87168cf0dc9 100644
--- a/gas/testsuite/gas/scfi/x86_64/scfi-pushsection-2.d
+++ b/gas/testsuite/gas/scfi/x86_64/scfi-pushsection-2.d
@@ -1,7 +1,7 @@
#as: --scfi=experimental -W
#as:
#objdump: -Wf
-#name: Synthesize CFI for demarcated code blocks 2
+#name: Synthesize CFI with pushsection 2
#...
Contents of the .eh_frame section:
More information about the Binutils-cvs
mailing list