gdb and binutils branch master updated. bad1aba328293fc62831ac451edc55adc37ead36
mpf@sourceware.org
mpf@sourceware.org
Tue May 13 11:03:00 GMT 2014
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".
The branch, master has been updated
via bad1aba328293fc62831ac451edc55adc37ead36 (commit)
from 51e719b4e118f69862775772053059700a331097 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=bad1aba328293fc62831ac451edc55adc37ead36
commit bad1aba328293fc62831ac451edc55adc37ead36
Author: mfortune <matthew.fortune@imgtec.com>
Date: Tue May 13 11:55:08 2014 +0100
Re-work register size macros for MIPS.
gas/
* config/tc-mips.c (mips_set_options): Rename gp32 to gp throughout.
(HAVE_32BIT_GPRS, HAVE_64BIT_GPRS): Remove. Re-implement via GPR_SIZE.
(HAVE_32BIT_FPRS, HAVE_64BIT_FPRS): Remove. Re-implement via FPR_SIZE.
(GPR_SIZE, FPR_SIZE): New macros. Use throughout.
-----------------------------------------------------------------------
Summary of changes:
gas/ChangeLog | 7 +++
gas/config/tc-mips.c | 140 +++++++++++++++++++++++++------------------------
2 files changed, 78 insertions(+), 69 deletions(-)
hooks/post-receive
--
gdb and binutils
More information about the Binutils-cvs
mailing list