src/gas ChangeLog dw2gencfi.c

amodra@sourceware.org amodra@sourceware.org
Sat May 7 05:37:00 GMT 2011


CVSROOT:	/cvs/src
Module name:	src
Changes by:	amodra@sourceware.org	2011-05-07 05:37:55

Modified files:
	gas            : ChangeLog dw2gencfi.c 

Log message:
	* dw2gencfi.c (CUR_SEG, SET_CUR_SEG, HANDLED, SET_HANDLED): Define.
	Use throughout in place of #if SUPPORT_FRAME_LINKONCE.
	(struct fde_entry): Rename cseg to cur_seg.
	(cfi_change_reg_numbers): Remove ATTRIBUTE_UNUSED.
	(get_cfi_seg): Likewise.  Use if (SUPPORT_FRAME_LINKONCE) rather
	that #if SUPPORT_FRAME_LINKONCE.
	(cfi_finish): Likewise.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/ChangeLog.diff?cvsroot=src&r1=1.4475&r2=1.4476
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/dw2gencfi.c.diff?cvsroot=src&r1=1.53&r2=1.54



More information about the Binutils-cvs mailing list