src/bfd ChangeLog vms-alpha.c

gingold@sourceware.org gingold@sourceware.org
Fri May 6 10:41:00 GMT 2011


CVSROOT:	/cvs/src
Module name:	src
Changes by:	gingold@sourceware.org	2011-05-06 10:41:12

Modified files:
	bfd            : ChangeLog vms-alpha.c 

Log message:
	2011-05-06  Tristan Gingold  <gingold@adacore.com>
	
	* vms-alpha.c (evax_section_flags): Remove SEC_IN_MEMORY.
	(_bfd_vms_slurp_egsd): Rename old_flags to vms_flags.  Handle
	any code section.  Add comments.
	(alpha_vms_object_p): Use void * instead of PTR.
	(alpha_vms_create_eisd_for_section): Fix test for setting DZRO.
	(build_module_list): Guard against no DST section.  Add comments.
	(alpha_vms_link_output_symbol): Discard undefined symbols.
	(alpha_vms_get_section_contents): Simply memcpy if the section was
	already loaded.  Fix typo.
	(vms_new_section_hook): Use void * instead of PTR.
	(vms_alpha_vec): Ditto.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/ChangeLog.diff?cvsroot=src&r1=1.5330&r2=1.5331
http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/vms-alpha.c.diff?cvsroot=src&r1=1.43&r2=1.44



More information about the Binutils-cvs mailing list