src/bfd ChangeLog elfxx-mips.c

chaoyingfu@sourceware.org chaoyingfu@sourceware.org
Wed Jan 13 22:30:00 GMT 2010


CVSROOT:	/cvs/src
Module name:	src
Changes by:	chaoyingfu@sourceware.org	2010-01-13 22:30:54

Modified files:
	bfd            : ChangeLog elfxx-mips.c 

Log message:
	2010-01-13  Chao-ying Fu  <fu@mips.com>
	
	* elfxx-mips.c (JR_TO_B_P): New define to transform JR to B.
	It is true for all CPUs.
	(jal_reloc_p): New function.
	(mips_elf_calculate_relocation): Rename require_jalxp to
	cross_mode_jump_p.
	Update comment for CROSS_MODE_JUMP_P.
	Set up cross_mode_jump_p based on the mode change.
	(mips_elf_perform_relocation): Rename require_jalx to cross_mode_jump_p.
	Update comment for CROSS_MODE_JUMP_P.
	Test cross_mode_jump_p and jal_reloc_p to turn jal to jalx.
	Use !cross_mode_jump_p to guard conversion.
	Convert "jr t9" to "b", if possible.
	(_bfd_mips_elf_relocate_section): Rename require_jalx to
	cross_mode_jump_p.
	Pass &cross_mode_jump_p to call mips_elf_calculate_relocation.
	Pass cross_mode_jump_p to call mips_elf_perform_relocation.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/ChangeLog.diff?cvsroot=src&r1=1.4891&r2=1.4892
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/elfxx-mips.c.diff?cvsroot=src&r1=1.264&r2=1.265



More information about the Binutils-cvs mailing list