src/ld/testsuite ChangeLog ld-elf/eh-frame-hdr ...

jkratoch@sourceware.org jkratoch@sourceware.org
Sat Sep 20 08:42:00 GMT 2008


CVSROOT:	/cvs/src
Module name:	src
Changes by:	jkratoch@sourceware.org	2008-09-20 08:42:53

Modified files:
	ld/testsuite   : ChangeLog 
	ld/testsuite/ld-elf: eh-frame-hdr.d eh-group.exp eh-group1.s 
	                     eh-group2.s eh5.d 
	ld/testsuite/lib: ld-lib.exp 

Log message:
	Provide virtual target "cfi" for targets supporting CFI.
	* ld-elf/eh-frame-hdr.d: Replace target and xfail statements by single
	`target: cfi'.
	* ld-elf/eh-group.exp: Call check_as_cfi instead of is_elf_format.
	* ld-elf/eh-group1.s, elf/eh-group2.s: Use more compatible section
	flags prefix '%'.
	* ld-elf/eh5.d: Replace target statement by `target: cfi' with an Alpha
	exception.  Relax the `Code alignment factor' matching.
	* lib/ld-lib.exp: Rename istarget as istarget_ld.
	(istarget, check_as_cfi): New procedure.
	(run_dump_test): New comment for the virtual target `cfi'.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/ChangeLog.diff?cvsroot=src&r1=1.970&r2=1.971
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/ld-elf/eh-frame-hdr.d.diff?cvsroot=src&r1=1.1&r2=1.2
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/ld-elf/eh-group.exp.diff?cvsroot=src&r1=1.1&r2=1.2
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/ld-elf/eh-group1.s.diff?cvsroot=src&r1=1.1&r2=1.2
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/ld-elf/eh-group2.s.diff?cvsroot=src&r1=1.1&r2=1.2
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/ld-elf/eh5.d.diff?cvsroot=src&r1=1.2&r2=1.3
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/lib/ld-lib.exp.diff?cvsroot=src&r1=1.54&r2=1.55



More information about the Binutils-cvs mailing list