src/bfd ChangeLog archive.c libbfd-in.h libbfd.h
bje@sourceware.org
bje@sourceware.org
Thu Mar 10 00:29:00 GMT 2005
CVSROOT: /cvs/src
Module name: src
Changes by: bje@sourceware.org 2005-03-10 00:29:37
Modified files:
bfd : ChangeLog archive.c libbfd-in.h libbfd.h
Log message:
* archive.c: Include hashtab.h.
(struct ar_cache): Rename `arelt' to `arbfd' and remove `next'.
(_bfd_look_for_bfd_in_cache): Reimplement using htab_find.
(hash_file_ptr): New function.
(eq_file_ptr): Likewise.
(_bfd_add_bfd_to_archive_cache): Reimplement using a hash table.
* libbfd-in.h: Include hashtab.h.
(struct artdata): Change `cache' member type to htab_t.
* libbfd.h: Rebuild.
Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/ChangeLog.diff?cvsroot=src&r1=1.2955&r2=1.2956
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/archive.c.diff?cvsroot=src&r1=1.34&r2=1.35
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/libbfd-in.h.diff?cvsroot=src&r1=1.46&r2=1.47
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/libbfd.h.diff?cvsroot=src&r1=1.137&r2=1.138
More information about the Binutils-cvs
mailing list