src/binutils ChangeLog objdump.c

nathan@sources.redhat.com nathan@sources.redhat.com
Mon Mar 15 12:31:00 GMT 2004


CVSROOT:	/cvs/src
Module name:	src
Changes by:	nathan@sourceware.org	2004-03-15 12:31:42

Modified files:
	binutils       : ChangeLog objdump.c 

Log message:
	* objdump.c (struct SFILE): Replace current pointer with pos
	offset, rename size to alloc.
	(objdump_sprintf): Avoid unnecessary copies in the common case
	(disassemble_bytes): Keep sfile live throughout the
	function. Adjust usage appropriately.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/binutils/ChangeLog.diff?cvsroot=src&r1=1.746&r2=1.747
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/binutils/objdump.c.diff?cvsroot=src&r1=1.86&r2=1.87



More information about the Binutils-cvs mailing list