src/bfd ChangeLog elf64-ppc.c

amodra@sources.redhat.com amodra@sources.redhat.com
Wed Aug 6 12:23:00 GMT 2003


CVSROOT:	/cvs/src
Module name:	src
Changes by:	amodra@sourceware.org	2003-08-06 12:23:38

Modified files:
	bfd            : ChangeLog elf64-ppc.c 

Log message:
	* elf64-ppc.c (ppc_stub_name): Tweak names for better readability.
	(ppc64_elf_adjust_dynamic_symbol): Allow copy relocs against
	function descriptors, but warn.
	(ppc_build_one_stub): Remove a couple of vars.  Move code creating
	stub syms so that we can avoid a stub sym if we already have a
	plt sym.  Do not redefine an existing symbol.
	(ppc64_elf_build_stubs): When --emit-stub-syms, print a symbol for
	glink.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/ChangeLog.diff?cvsroot=src&r1=1.2217&r2=1.2218
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/bfd/elf64-ppc.c.diff?cvsroot=src&r1=1.123&r2=1.124



More information about the Binutils-cvs mailing list