[python][rfc] rename Frame.read_var_value to Frame.read_var
Thiago Jung Bauermann
bauerman@br.ibm.com
Tue Mar 3 17:34:00 GMT 2009
El mar, 03-03-2009 a las 09:26 -0700, Tom Tromey escribió:
> >>>>> "Thiago" == Thiago Jung Bauermann <bauerman@br.ibm.com> writes:
>
> Thiago> I think the method read_var_value in gdb.Frame should be renamed to the
> Thiago> shorter name read_var. This patch makes the change. WDYT?
>
> It is fine by me; I agree that "_value" is redundant.
>
> Did you consider the unabbreviated "read_variable"?
No, do you think it's better? I slightly prefer the shorter version as
it save some keystrokes and "var" is easy to recognize, but I wouldn't
mind using the unabberviated name.
--
[]'s
Thiago Jung Bauermann
IBM Linux Technology Center
More information about the Archer
mailing list