This is the mail archive of the mailing list for the newlib project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Porting newlib new backend

Here is what I did :

        cd newlib-2.0.0
        cd libgloss
        cd eco32
        aclocal -I ..
        cd ../..
        cd newlib/
        cd libc/
        aclocal -I .. -I../..
automake --cygnus Makefile argz/Makefile ctype/Makefile errno/Makefile \ iconv/Makefile locale/Makefile misc/Makefile posix/Makefile reent/Makefile \ search/Makefile signal/Makefile stdio/Makefile stdio64/Makefile stdlib/Makefile string/Makefile syscalls/Makefile time/Makefile unix/Makefile iconv/ccs/Makefile iconv/ces/Makefile iconv/lib/Makefile \ iconv/ccs/binary/Makefile
        cd machine/
        cd <target>/
        aclocal -I ../../..
        automake --cygnus Makefile

Let me know if it worked :)

With best regards
 Jens Mehler

Am 29.08.13 17:56, schrieb Hendrik Greving:
Did you rebuild just by running aclocal, autoreconf, or more than that?
Hendrik Greving

On Thu, Aug 29, 2013 at 8:47 AM, Jens Mehler <> wrote:
Hi Hendrik,

I ran into the same issue a few weeks ago.
Try to rebuild the configure files in the respective directories.

With best regards
Jens Mehler

Am 29.08.13 17:33, schrieb Hendrik Greving:

Hi, I have 'ported' newlib to a new backend, adding
sys/<myarch>/crt0.S (simplified crt0 for our machine).

When configuring/building, integrated into fsf (GCC) directory, I am
getting the error

/my/path/obj/fsf/./binutils/ranlib lib.a
make[5]: Leaving directory `/my/path/obj/fsf/<myarch>/newlib/libc/locale'
Making all in sys
make[5]: Entering directory `/my/path/obj/fsf/<myarch>/newlib/libc/sys'
Making all in <myarch>
/bin/sh: line 0: cd: <myarch>: No such file or directory
Making all in .
make[6]: Entering directory `/my/path/obj/fsf/<myarch>/newlib/libc/sys'
make[6]: *** No rule to make target `<myarch>/lib.a', needed by `lib.a'.
make[6]: Leaving directory `/my/path/obj/fsf/<myarch>/newlib/libc/sys'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/my/path/obj/fsf/<myarch>/newlib/libc/sys'
Making all in reent

Any hints what i might miss? I did add sys_dir=<myarch> to, and ran aclocal and autoreconf.

Hendrik Greving

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]