This is the mail archive of the mailing list for the newlib project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Adding new target to newlib

Hi Jeff,

I got it figured out with a lot of patience and reading up on autotools.
The source is in my hands because I am still studying MSC Informatics so no worries about that.

The problem (in detail) was that I had the wrong version if autoconf and automake installed and therefore couldn't use aclocal and autoconf. After fixing that problem all I had to to was running autoconf in all directories where was modified. Additionally I had to use autoheaders and automake in my own target directories.

Long story short: It configures and builds :)
Sorry for all that fuzz, it was a really long day.

With best regards,

Am 30.07.13 22:00, schrieb Jeff Johnston:

If you are free to post your configuration files to a public list or to me personally (i.e. you can verify that you wrote 100% of the code and have permission from your employer to post it), it would make it much easier to help you.

There is a brief set of tasks in the newlib faq section of the web-site: (see item 6) to see if you missed anything.

You need to configure from the top-level src directory (where newlib and libgloss are siblings, not from newlib or below it) if you are not doing so.


-- Jeff J.

On 07/30/2013 09:31 AM, Jens Mehler wrote:
Hello folks,

I have succesfully ported GCC and Binutils for a new CPU (32bit RISC) .
I took up the afford and tried to port newlib for that processor too.
What I did:
1) I selected an already existing target and changed whatever needed changing.
2) I followed the guide for the or32

In both cases I can't seem to succesfully make my target.

This is the part of the make output that complains about my target:
Makefile:1438: warning: overriding commands for target `lib_a-mbtowc_r.o' Makefile:788: warning: ignoring old commands for target `lib_a-mbtowc_r.o' Makefile:1640: warning: overriding commands for target `lib_a-vfwscanf.o' Makefile:1375: warning: ignoring old commands for target `lib_a-vfwscanf.o'
/bin/sh: Zeile 0: cd: eco32: No such file or directory
cp: eco32/lib.a: No such file or directory
make[6]: *** [lib.a] Error 1
make[5]: *** [all-recursive] Error 1
eco32-ar: ../machine/lib.a: No such file or directory
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-target-newlib] Error 2
make: *** [all] Error 2

The problem could be in my configuration files because autoconf and co. won't really run because the version seems to be to new on my system.

I would really appreaciate some pointers into the right direction.
After rewriting the configuration files over and over again I hope someone can help me out a little.

With best regards,
Jens Mehler

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]