This is the mail archive of the mailing list for the newlib project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: arm[eb]-eabi-gcc for cortex-r4[f] with newlib has problems with multilib/libraries.

On 05/07/13 10:01, Will Newton wrote:
> On 4 July 2013 22:25, David Fernandez
> <> wrote:
>> Hi there,
>> Given my problem in the e-mail below, which nobody in crossgcc seems to
>> get any idea about it so far, I was wondering if it could have something
>> to do with newlib itself. The problem looks like the newlib strlen gets
>> compiled for the armv7-a architecture, regardless of specifying both the
>> cortex-r4[f] cpu, and the armv7-r architecture as defaults when building
>> the arm-eabi-gcc.
>> There is a proposed patch for newlib that made me suspect that the
>> armv7-a might be hard-coded somehow in the strlen implementation:
> Hi David,
> Have you tried a build with that patch applied i.e. current newlib HEAD?
> It looks like the old code explicitly set the architecture, whereas
> the new code doesn't. Alternatively you could try deleting the line in
> newlib/libc/machine/arm/strlen-armv7.S:
> .arch armv7-a
> --
> Will Newton
> Toolchain Working Group, Linaro
Hi Will,

I've tried to use the anoncvs, but I need to know the required modules
to checkout, in addition to newlib and libgloss, as with those two, gcc
complains of missing files:

configure: error: cannot find install-sh,, or shtool in ..

Could you let me know what are they?. Usually I link the folders newlib
and libgloss from newlib released sources into gcc source folder, but
the cvs modules seem to have some things missing.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]