This is the mail archive of the
mailing list for the newlib project.
Re: [PATCH] Use offsetof instead of magic number in scandir()
- From: Corinna Vinschen <vinschen at redhat dot com>
- To: newlib at sourceware dot org
- Date: Thu, 28 Mar 2013 13:42:41 +0100
- Subject: Re: [PATCH] Use offsetof instead of magic number in scandir()
- References: <1364468303-7319-1-git-send-email-sebastian dot huber at embedded-brains dot de> <20130328111705 dot GI11431 at calimero dot vinschen dot de> <51542D28 dot 7020708 at embedded-brains dot de>
- Reply-to: newlib at sourceware dot org
On Mar 28 12:44, Sebastian Huber wrote:
> On 03/28/2013 12:17 PM, Corinna Vinschen wrote:
> >Shouldn't we better use the upstream version as used in FreeBSD and
> > #define DIRSIZ(dp) \
> > ((sizeof(struct dirent) - sizeof(dp)->d_name) + \
> > (((dp)->d_namlen + 1 + 3) &~ 3))
> I have problems to understand this expression. What is
> "sizeof(dp)->d_name"? I think this looks like a hand-crafted
> offsetof variant.
sizeof(dp)->d_name is sizeof((dp)->d_name), but without the lexically
unnecessary parens. I was just thinking that using the upstream
version has the advnatage to use easier comparable code, given that
our scandir.c is the BSD version anyway.