This is the mail archive of the mailing list for the newlib project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

building GCC cross toolchain for mips


We have been generating toolchain for MIPS for some time and it used to work well
We have upgraded before to the following versions

With these versions we can also generate binutils, gcc and newlib for target="mips-none-elf"
No problem.
Next we have tried to do the same with V_NEWLIB=2.0.0
Then we can build binutils and gcc. But when we make newlib we get

*Error*: *opcode* not supported on this processor: mips1 ... mips1 (mips1) *pref*

What happened ?
Should we now use a different target ?
The configure newlib we have

    "$SRC_DIR"/newlib-$V_NEWLIB/configure --host=$HOST --build=$BUILD \
        --target=mips-none-elf --prefix="$INSTALL_DIR" --disable-nls

Then when compiling memcpy.S in newlib , I get:
opcode not supported on this processor: mips1 (mips1) `pref

but it seems the opcode is not found is because the assembler generated
by binutils does not support pref !

I also tried with target=mipsisa64r2

Then I get
memcpy.S:389: Error: Illegal operands `ld t4,((4)*8)($5)'

Is it a binutils problem or a newlib problem?
However it works with newlib 1.20....

Which target do I need to use to have binutils , gcc and newlib
for both mips32 and mips64 architecture ?

Do I need to use argument --with-extra-multilibs= ??

Comments appreciated.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]