This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Question regarding patchwork patches


Dear Paul, Albert,

I would like to ask about the status of following patchwork patches:

https://patchwork.ozlabs.org/patch/1015947/
[1/2] Y2038: make __mktime_internal compatible with __time64_t

and 

https://patchwork.ozlabs.org/patch/1015948/
[2/2] Fix time/mktime.c and time/gmtime.c for gnulib compatibility

The second one looks like changes necessary for gnulib to make it
working.

However, both seems to be relevant for Y2038 support. If I may ask -
are there any issues with including those two patches into the glibc?

I've checked and those clearly apply on top of <glibc-2.29> tag.



A side question - commit messages above mention about: x86_64-linux-gnu
and i686-linux.gnu toolchains.

The "toolchain" note for 2.29:

* On most architectures, GCC 5 or later is required to build the GNU C
  Library.  (On powerpc64le, GCC 6.2 or later is still required, as
  before.)

  Older GCC versions and non-GNU compilers are still supported when
  compiling programs that use the GNU C Library.


Could you share the version used for testing those patches (and if
possible the name/url)?

Thanks in advance for help.

Best regards,

Lukasz Majewski

--

DENX Software Engineering GmbH,      Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-59 Fax: (+49)-8142-66989-80 Email: lukma@denx.de

Attachment: pgp9PHL5iyzkE.pgp
Description: OpenPGP digital signature


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]