This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Requiring Linux 3.2 for glibc 2.24


As Linux 2.6.32 has been announced to reach end-of-line next month 
<https://lkml.org/lkml/2016/1/29/647>, I propose that for glibc 2.24 we 
require Linux 3.2 as the minimum kernel version when glibc is used on 
systems with the Linux kernel and there isn't already a more recent 
architecture-specific minimum.  This would continue to be the minimum 
until 3.2 reaches EOL (currently listed as May 2018 at 
<https://www.kernel.org/category/releases.html>).  3.2 would thus also be 
the minimum headers version as well as the minimum version at runtime.

This would eliminate every version-specific conditional in the 
architecture-independent kernel-features.h as well as those for alpha mips 
powerpc sh sparc tile x86_64 and some version-specific conditionals in 
headers for other architectures.  How this translates into simplifying 
other code varies, since some macros may still be undefined for some 
architectures (unconditionally or conditionally on a post-3.2 version), 
and some __ASSUME_* macros are tested in code also used on non-Linux 
systems.

-- 
Joseph S. Myers
joseph@codesourcery.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]