This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Use "_" prefix for macro variables, and harmonize variable names for sysdep syscall macros.


On 06/12/2015 05:35 AM, Andreas Schwab wrote:
> "Carlos O'Donell" <carlos@redhat.com> writes:
> 
>> +	register unsigned long _sc_ret asm("r28");			\
>> +	PIC_REG_DEF							\
>> +	LOAD_ARGS_##nr(args)						\
>> +	/* FIXME: HACK save/load r19 around syscall */			\
>> +	asm volatile(							\
>> +		SAVE_ASM_PIC						\
>> +		"	ble  0x100(%%sr2, %%r0)\n"			\
>> +		"	ldi %1, %%r20\n"				\
>> +		LOAD_ASM_PIC						\
>> +		: "=r" (_sc_ret)					\
>> +		: "i" (SYS_ify(name)) PIC_REG_USE ASM_ARGS_##nr		\
>> +		: "memory", CALL_CLOB_REGS CLOB_ARGS_##nr		\
>> +	);								\
>> +	if ( (unsigned long)_sc_ret >= (unsigned long)-4095 ){		\
> 
> The cast isn't needed any more, and (unsigned long)-4095 can better be
> written as -4095UL.

Thanks. I'll make the change as a follow-up patch.

Cheers,
Carlos.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]