This is the mail archive of the guile-emacs@sourceware.cygnus.com mailing list for the Guile project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

make failed on FreeBSD 3.4R


Hi, I tried to compile guile-emacs-0.4 on FreeBSD 3.4R but
it failed.  I attached a quick patch for fixing the problem.

  % ./configure
  (snip) 
  creating ./config.status
  creating Makefile
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating lib-src/Makefile.c
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating oldXMenu/Makefile
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating lwlib/Makefile
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating src/Makefile.c
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating lisp/Makefile
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating doc/Makefile
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating tools/Makefile
  sed: 54: conftest.s1: unescaped newline inside substitute pattern
  creating src/config.h
  creating src/epaths.h
  make: don't know how to make epaths-force. Stop
  creating lib-src/Makefile
  creating src/Makefile

-- Satoru Takabayashi

*** configure.in.orig	Sun May 28 21:46:00 2000
--- configure.in	Sun May 28 21:47:31 2000
***************
*** 1,4 ****
- Executing ssh-askpass to query the password...
  dnl  Autoconf script for Guile Emacs
  dnl To rebuild the `configure' script from this, execute the command
  dnl 	autoconf
--- 1,3 ----
***************
*** 40,48 ****
  $EMACS --version > /dev/null || \
    AC_MSG_ERROR([You have to install GNU Emacs 20.6 first.])
  echo '(message data-directory)' > .tmp.el
! $EMACS -batch -l .tmp.el 2> .tmp.out
  emacsdir=`sed 's/\/[[0-9]].*//' .tmp.out`
! emacsver=`sed 's/^[[^0-9]]*\([[0-9]]\+\.[[0-9]]\+\).*/\1/' .tmp.out`
  if test `echo $emacsver | sed 's/\..*//'` != "20"; then
    AC_MSG_ERROR([You have to install GNU Emacs 20.6.])
  fi
--- 39,47 ----
  $EMACS --version > /dev/null || \
    AC_MSG_ERROR([You have to install GNU Emacs 20.6 first.])
  echo '(message data-directory)' > .tmp.el
! $EMACS -batch -l .tmp.el 2>&1 |tail -1 >  .tmp.out
  emacsdir=`sed 's/\/[[0-9]].*//' .tmp.out`
! emacsver=`sed 's/^[[^0-9]]*\/\([[0-9\.]]*\)\/.*/\1/' .tmp.out`
  if test `echo $emacsver | sed 's/\..*//'` != "20"; then
    AC_MSG_ERROR([You have to install GNU Emacs 20.6.])
  fi

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]