This is the mail archive of the gdb@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[RFC] "actionpoints"?


One of the issues that has come up regularly in our tracepoint work is what GDB's messages to the user should say when they are referring to various combinations of tracepoints and breakpoints. We haven't dealt with it consistently so far, sometimes writing code to specifically say "tracepoint" when all the objects are tracepoints, sometimes saying "or" with several types, and sometimes relying on GDB's overloading of "breakpoint" to mean both stopping places and anything that uses the breakpoint.c infrastructure.

Although we've been doing the overloading for a long time, it's really abusing our terminology, and has to be confusing to users.

It turns out there is a generic term available - "actionpoint". It originally comes from TotalView I think, and was adopted into the HPD (high performance debugger) spec back in the 90s.

A plus is that the term is sufficiently vague that it is sensible for watchpoints, catchpoints, tracepoints, breakpoints, and the rest of the menagerie, including future ideas we haven't thought of yet. A minus is that it means having to teach an unfamiliar term to users, and it entails a certain amount of hacking up the manual.

There is also the risk that some (and you know who you are :-) ) will feel an overwhelming urge to rename source code to actionpoint.c, struct actionpoint, etc, which I *don't* want to do - it's a lot of busywork that doesn't directly help the user. Right now I just want to think about how to give good feedback to users; should we introduce a new term, continue using "breakpoint", concoct phrases with "/" and "or", or do something else entirely?

Stan


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]