This is the mail archive of the
mailing list for the GDB project.
Re: [PATCH v3 3/4] Introduce field_unsigned
On 7/17/19 2:31 PM, Tom Tromey wrote:
> Pedro> Given the existence of "field_int", I'd expect "unsigned" to print an
> Pedro> unsigned (int), not a ULONGEST.
> Pedro> (I was initialize surprised it wasn't called field_uint, like the
> Pedro> ui_out_field_uint function that is removed by this patch, until I
> Pedro> realized this works with a ULONGEST.)
> Pedro> To output a ULONGEST, I'd expect the method to be called field_ulongest.
> Pedro> Is your plan to rename field_int to field_signed, perhaps?
> I hadn't really considered it, but I can rename either one as you like.
> I tend to think field_int should accept a LONGEST rather than an int.
> So I suppose doing that & naming it field_signed would be a way to go.
Right, I meant to ask whether the plan was to rename AND change
to LONGEST, for didn't for some reason.
That would work for me.
> What do think?