This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA 0/9] Radically simplify the complaint system


On 05/22/2018 06:06 AM, Tom Tromey wrote:
> I must confess, I've long disliked the complaint system.  It got in
> the way a little bit, ages ago, when I tried to multi-thread the
> psymtab reader.  And, it got in the way a bit more during one of my
> attempts to format the "Reading symbols" output more nicely (spoiler:
> I have another approach to this in the works, but I took this detour
> first).  Aside from these things, the code also seemed unusually
> complex for the task it performed.
> 
> This series radically simplifies the complaint system.  It removes
> most of the code -- which, I think, has never really been used.

Awesome!  I started doing something similar a while ago after adding
the complaint wrapper macro, but never really finished it off:

  https://github.com/palves/gdb/tree/palves/complaints

Probably nothing worth looking over.

This looks good to me, but I have one question:

Can you give an example case of when do we still need or want
the ISOLATED_MESSAGE vs SHORT_FIRST_MESSAGE distinction?
I removed it from my version, but I don't recall whether I
concluded the distinction made no difference, or whether
I still wanted to double check.  Off hand, since we're
admitting that complaints are only for debug info reading,
I'd think the distinction doesn't make much sense.  Unless
we're really not admitting that?  /me confused, I guess.

> Tested by the buildbot.  I also locally tested complaints.exp with
> each patch in the series.
Note: git am showed:

Applying: Remove symfile_complaints
.git/rebase-apply/patch:247: trailing whitespace.
vcomplaint (const char *file, 
.git/rebase-apply/patch:253: trailing whitespace.
  struct complain *complaint = find_complaint (&symfile_complaint_book, file, 
.git/rebase-apply/patch:2497: trailing whitespace.
              complaint (_("Bad method name '%s'"), 
warning: 3 lines add whitespace errors.

Thanks,
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]