This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 4/5] Handle breakpoint kinds for software breakpoints in GDBServer.




On 09/28/2015 06:33 AM, Yao Qi wrote:
Antoine Tremblay <antoine.tremblay@ericsson.com> writes:

diff --git a/gdb/gdbserver/target.h b/gdb/gdbserver/target.h
index 603819e..bf4c3c7 100644
--- a/gdb/gdbserver/target.h
+++ b/gdb/gdbserver/target.h
@@ -446,6 +446,10 @@ struct target_ops
       can be NULL, the default breakpoint for the target should be returned in
       this case.  */
    const unsigned char *(*breakpoint_from_pc) (CORE_ADDR *pcptr, int *lenptr);
+
+  /* Returns a breakpoint from a length, the length can have target specific
+     meaning like the z0 kind parameter.  */
+  const unsigned char *(*breakpoint_from_length) (int *len);
  };

If you agree on my comments to patch 2/5, we can rename this hook to
breakpoint_from_z0_kind.


I've renamed this to breakpoint_from_kind since I want to be able to reuse the same operation for future tracepoint kinds and don't want the confusion with z0.

This follows the terminology introduced in patch 2/5 in general too.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]