This is the mail archive of the
mailing list for the GDB project.
Re: [ppc64le patch v3] Use skip_entrypoint for skip_trampoline_code
- From: Jan Kratochvil <jan dot kratochvil at redhat dot com>
- To: Ulrich Weigand <uweigand at de dot ibm dot com>
- Cc: gdb-patches at sourceware dot org
- Date: Tue, 15 Sep 2015 18:50:19 +0200
- Subject: Re: [ppc64le patch v3] Use skip_entrypoint for skip_trampoline_code
- Authentication-results: sourceware.org; auth=none
- References: <20150910211720 dot GA12453 at host1 dot jankratochvil dot net> <20150915163917 dot C1F302209 at oc7340732750 dot ibm dot com>
On Tue, 15 Sep 2015 18:39:17 +0200, Ulrich Weigand wrote:
> This is OK.
Thanks for the ppc64le arch review but I am not sure if it is also approval of
the coding style which I asked about (not specifically you) by:
On Mon, 07 Sep 2015 22:47:20 +0200, Jan Kratochvil wrote:
# Currently gdbarch_skip_entrypoint() has been called in skip_prologue_sal() and
# fill_in_stop_func() but that is not enough. I believe
# gdbarch_skip_entrypoint() should be called after every
# gdbarch_skip_trampoline_code(), shouldn't it?
# The attached patch is a bit hack but I am not sure what is a clean solution.
# Maybe create a gdbarch_skip_trampoline_code() wrapper function calling also
# gdbarch_skip_entrypoint() and forbid calling gdbarch_skip_trampoline_code()
I did not want to refactor it before asking as there are too many
possibilities how to do it and I expect I would not guess the right one.
OTOH the refactorization can be also considered a future task, if you mean it