This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Fix gdb.dwarf2/dw2-dir-file-name.exp test for MIPS architectures


On 10/11/2014 10:01 PM, Kwok Cheung Yeung wrote:
> This patch fixes the failures that occur with the 
> gdb.dwarf2/dw2-dir-file-name.exp test on 64-bit MIPS and compressed MIPS 
> ISAs (i.e. MIPS16 and microMIPS).
> 
> The failures on 64-bit occur because the generated DWARF address 
> information is always 32-bit, which causes the upper 32-bits of 
> addresses to be truncated and causes breakpoints to be set on the wrong 
> address if any of the upper 32-bits are non-zero. I suspect that other 
> 64-bit architectures get away with it because they place all their 
> instructions at a VMA lower than 2^32 by default. This patch causes 
> 64-bit addresses to be generated if a 64-bit target is detected.
> 
> The failures on MIPS16 and microMIPS occur because the breakpoint 
> address needs to have the LSB set to 1 (used to indicate that the code 
> is compressed). However, the function name is interpreted as a data 
> label, causing GDB to set breakpoints at even addresses. This is fixed 
> by explicitly adding a '.insn' directive (see 
> https://sourceware.org/binutils/docs/as/MIPS-insn.html) after the label 
> on MIPS only.

Looks fine to me, but I'd like to hear Maciej's OK on the MIPS  specifics too.

Please make sure x86_64 still works.

I wonder if this test could be simplified using the testsuite's dwarf
assembler (Dwarf::assemble).

> 
> Kwok
> 
> 2014-08-14  Kwok Cheung Yeung  <kcy@codesourcery.com>
> 
> 	gdb/testsuite/
> 	* gdb.dwarf2/dw2-dir-file-name.exp (addr_len): New.
> 	(out_cu): Use addr_len for the size of addresses.
> 	(out_line): Likewise.  Size DW_LNE_set_address instruction
> 	according to addr_len.
> 	* gdb.dwarf2/dw2-dir-file-name.c (START_INSNS): New.
> 	(FUNC): Add START_INSNS to definition.
> 


Thanks,
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]