This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Refactor common/target-common into meaningful bits


On 08/16/2013 03:49 PM, Luis Machado wrote:

> This is an updated version of the patch that drops the target-* naming, 
> creates a new directory named "target" under src/gdb and renames the 
> files target-<something>.* to <something.*.
> 
> Based on previous discussions, it seems this is what it should look like 
> in the future.
> 
> One of the differences now is the inclusion of, for example, 
> "target/resume.h" instead of "resume.h". It looks more intuitive this way.

Yes, and the corresponding '#include "wait.h"' would collide with
the system's /usr/include/wait.h.

> -target-common.o: ${srcdir}/common/target-common.c
> -	$(COMPILE) $(srcdir)/common/target-common.c
> +target-waitstatus.o: ${srcdir}/target/waitstatus.c

Any reason this isn't waitstatus.o?

> @@ -550,7 +552,7 @@ filestuff.o: ../common/filestuff.c
>  agent.o: ../common/agent.c
>  	$(COMPILE) $<
>  	$(POSTCOMPILE)
> -target-common.o: ../common/target-common.c
> +target-waitstatus.o: ../target/waitstatus.c
>  	$(COMPILE) $<
>  	$(POSTCOMPILE)

Here too.

Otherwise looks fine to me.

Thanks,
-- 
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]