This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH v7 1/3] MI: add the -catch-load and -catch-unload commands


On 29.11.2012 03:05, Mircea Gherzan wrote:
They are equivalent to "catch load" and "catch unload" from CLI.

Rationale: GUIs might be interested in catching solib load or
unload events.

2012-11-16 Mircea Gherzan<mircea.gherzan@intel.com>

	* Makefile.in (SUBDIR_MI_OBS): Add mi-cmd-catch.o.
	(SUBDIR_MI_SRCS): Add mi/mi-cmd-catch.c.
	* breakpoint.c (add_solib_catchpoint): New function based on
	that can be used by both CLI and MI, factored out from
	catch_load_or_unload.
	(catch_load_or_unload): Strip it down and make it use the
	new add_solib_catchpoint.
	* breakpoint.h (add_solib_catchpoint): Declare it.
	* mi/mi-cmd-catch.c: New file.
	* mi/mi-cmds.c (mi_cmds): Add the handlers for -catch-load
	and -catch-unload.
	* mi/mi-cmds.h: Declare the handlers for -catch-load and
	-catch-unload.

Signed-off-by: Mircea Gherzan<mircea.gherzan@intel.com>
---
  gdb/Makefile.in       |    9 +++-
  gdb/breakpoint.c      |   33 +++++++++----
  gdb/breakpoint.h      |    5 ++
  gdb/mi/mi-cmd-catch.c |  126 +++++++++++++++++++++++++++++++++++++++++++++++++
  gdb/mi/mi-cmds.c      |    4 ++
  gdb/mi/mi-cmds.h      |    2 +
  6 files changed, 167 insertions(+), 12 deletions(-)
  create mode 100644 gdb/mi/mi-cmd-catch.c

diff --git a/gdb/Makefile.in b/gdb/Makefile.in
index 3dd7b85..40c7e80 100644
--- a/gdb/Makefile.in
+++ b/gdb/Makefile.in
@@ -203,13 +203,14 @@ SUBDIR_CLI_CFLAGS=
  #
  SUBDIR_MI_OBS = \
  	mi-out.o mi-console.o \
-	mi-cmds.o mi-cmd-env.o mi-cmd-var.o mi-cmd-break.o mi-cmd-stack.o \
+	mi-cmds.o mi-cmd-catch.o mi-cmd-env.o \
+	mi-cmd-var.o mi-cmd-break.o mi-cmd-stack.o \
  	mi-cmd-file.o mi-cmd-disas.o mi-symbol-cmds.o mi-cmd-target.o \
  	mi-cmd-info.o mi-interp.o \
  	mi-main.o mi-parse.o mi-getopt.o
  SUBDIR_MI_SRCS = \
  	mi/mi-out.c mi/mi-console.c \
-	mi/mi-cmds.c mi/mi-cmd-env.c \
+	mi/mi-cmds.c mi/mi-cmd-catch.c mi/mi-cmd-env.c \
  	mi/mi-cmd-var.c mi/mi-cmd-break.c mi/mi-cmd-stack.c \
  	mi/mi-cmd-file.c mi/mi-cmd-disas.c mi/mi-symbol-cmds.c \
  	mi/mi-cmd-target.c mi/mi-cmd-info.c mi/mi-interp.c \
@@ -1833,6 +1834,10 @@ mi-cmd-break.o: $(srcdir)/mi/mi-cmd-break.c
  	$(COMPILE) $(srcdir)/mi/mi-cmd-break.c
  	$(POSTCOMPILE)

+mi-cmd-catch.o: $(srcdir)/mi/mi-cmd-catch.c
+	$(COMPILE) $(srcdir)/mi/mi-cmd-catch.c
+	$(POSTCOMPILE)
+
  mi-cmd-disas.o: $(srcdir)/mi/mi-cmd-disas.c
  	$(COMPILE) $(srcdir)/mi/mi-cmd-disas.c
  	$(POSTCOMPILE)
diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
index 5749fa7..1c95c04 100644
--- a/gdb/breakpoint.c
+++ b/gdb/breakpoint.c
@@ -7847,20 +7847,16 @@ print_recreate_catch_solib (struct breakpoint *b, struct ui_file *fp)

static struct breakpoint_ops catch_solib_breakpoint_ops;

-/* A helper function that does all the work for "catch load" and
-   "catch unload".  */
+/* Shared helper function (MI and CLI) for creating and installing
+   a shared object event catchpoint.  */

-static void
-catch_load_or_unload (char *arg, int from_tty, int is_load,
-		      struct cmd_list_element *command)
+void
+add_solib_catchpoint (char *arg, int is_load, int is_temp, int enabled)
  {
    struct solib_catchpoint *c;
-  struct gdbarch *gdbarch = get_current_arch ();
-  int tempflag;
+  struct gdbarch *arch = get_current_arch ();

Is gdbarch->arch rename an essential part of this patch?


struct cleanup *cleanup;

-  tempflag = get_cmd_context (command) == CATCH_TEMPORARY;
-
    if (!arg)
      arg = "";
    arg = skip_spaces (arg);
@@ -7884,13 +7880,30 @@ catch_load_or_unload (char *arg, int from_tty, int is_load,
      }

    c->is_load = is_load;
-  init_catchpoint (&c->base, gdbarch, tempflag, NULL,
+  init_catchpoint (&c->base, arch, is_temp, NULL,
  		   &catch_solib_breakpoint_ops);

Same question here.



+ c->base.enable_state = enabled ? bp_enabled : bp_disabled; + discard_cleanups (cleanup); install_breakpoint (0, &c->base, 1); }

+/* A helper function that does all the work for "catch load" and
+   "catch unload".  */
+
+static void
+catch_load_or_unload (char *arg, int from_tty, int is_load,
+		      struct cmd_list_element *command)
+{
+  int tempflag;
+  const int enabled = 1;
+
+  tempflag = get_cmd_context (command) == CATCH_TEMPORARY;
+
+  add_solib_catchpoint (arg, is_load, tempflag, enabled);
+}
+
  static void
  catch_load_command_1 (char *arg, int from_tty,
  		      struct cmd_list_element *command)
diff --git a/gdb/breakpoint.h b/gdb/breakpoint.h
index 8b1bcb7..11e432c 100644
--- a/gdb/breakpoint.h
+++ b/gdb/breakpoint.h
@@ -1405,6 +1405,11 @@ extern void disable_breakpoints_in_shlibs (void);
  /* This function returns TRUE if ep is a catchpoint.  */
  extern int is_catchpoint (struct breakpoint *);

+/* Shared helper function (MI and CLI) for creating and installing
+   a shared object event catchpoint.  */
+extern void add_solib_catchpoint (char *arg, int is_load, int is_temp,
+                                  int enabled);
+
  /* Enable breakpoints and delete when hit.  Called with ARG == NULL
     deletes all breakpoints.  */
  extern void delete_command (char *arg, int from_tty);
diff --git a/gdb/mi/mi-cmd-catch.c b/gdb/mi/mi-cmd-catch.c
new file mode 100644
index 0000000..c7b494e
--- /dev/null
+++ b/gdb/mi/mi-cmd-catch.c
@@ -0,0 +1,126 @@
+/* MI Command Set - catch commands.
+   Copyright (C) 2012 Free Software Foundation, Inc.
+
+   Contributed by Intel Corporation.
+
+   This file is part of GDB.
+
+   This program is free software; you can redistribute it and/or modify
+   it under the terms of the GNU General Public License as published by
+   the Free Software Foundation; either version 3 of the License, or
+   (at your option) any later version.
+
+   This program is distributed in the hope that it will be useful,
+   but WITHOUT ANY WARRANTY; without even the implied warranty of
+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+   GNU General Public License for more details.
+
+   You should have received a copy of the GNU General Public License
+   along with this program.  If not, see<http://www.gnu.org/licenses/>.  */
+
+#include "defs.h"
+#include "arch-utils.h"
+#include "breakpoint.h"
+#include "gdb.h"
+#include "libiberty.h"
+#include "mi-cmds.h"
+#include "mi-getopt.h"
+#include "observer.h"
+#include "ui-out.h"
+
+/* True if MI breakpoint observers have been registered.  */
+
+static int mi_catchpoint_observers_installed;
+
+/* Control whether breakpoint_notify may act.  */
+
+static int mi_can_catchpoint_notify;
+
+/* Output a single breakpoint, when allowed.  */

Please s/breakpoint/catchpoint/g in comments above. But actually, see below


+
+static void
+catchpoint_notify (struct breakpoint *b)
+{
+  if (mi_can_catchpoint_notify)
+    gdb_breakpoint_query (current_uiout, b->number, NULL);
+}
+
+/* Common path for the -catch-load and -catch-unload.  */
+
+static void
+mi_catch_load_unload (int load, char *argv[], int argc)
+{
+  struct solib_catchpoint *c;
+  struct cleanup *back_to;
+  char *actual_cmd = load ? "-catch-load" : "-catch-unload";
+  int temp = 0;
+  int enabled = 1;
+  int oind = 0;
+  char *oarg;
+  enum opt
+    {
+      OPT_TEMP,
+      OPT_DISABLED,
+    };
+  static const struct mi_opt opts[] =
+    {
+      { "t", OPT_TEMP, 0 },
+      { "d", OPT_DISABLED, 0 },
+      { 0, 0, 0 }
+    };
+
+  for (;;)
+    {
+      int opt = mi_getopt (actual_cmd, argc, argv, opts,
+                           &oind, &oarg);
+
+      if (opt < 0)
+        break;
+
+      switch ((enum opt) opt)
+        {
+        case OPT_TEMP:
+          temp = 1;
+          break;
+        case OPT_DISABLED:
+          enabled = 0;
+          break;
+        }
+    }
+
+  if (oind >= argc)
+    error (_("-catch-load/unload: Missing <library name>"));
+  if (oind < argc -1)
+    error (_("-catch-load/unload: Garbage following the <library name>"));
+
+  if (! mi_catchpoint_observers_installed)
+    {
+      observer_attach_breakpoint_created (catchpoint_notify);
+      mi_catchpoint_observers_installed = 1;
+    }
+
+  back_to = make_cleanup_restore_integer (&mi_can_catchpoint_notify);
+  mi_can_catchpoint_notify = 1;

To be honest, I am unsure that implicit copy-paste of this logic is a great idea, especially given that catchpoint_notify and breakpoint_notify are identical. Maybe, a more appropriate solution would be to add this functionality to mi-cmd-break.c, and extract the above snippet into a function called 'setup_new_breakpoint_reporting'?

Thanks,

--
Vladimir Prus
CodeSourcery / Mentor Graphics
http://www.mentor.com/embedded-software/


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]