This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: collecting optimized out variables regression (Re: RFA: rewrite dwarf->ax translator (Was: RFC: implement DW_OP_bit_piece))


On Thu, 01 Jul 2010 14:42:59 +0200, Pedro Alves wrote:
> +  if (dlbaton->data == NULL || dlbaton->size == 0)

If SIZE != 0 then DATA must be != NULL otherwise GDB would crash elsewhere.

dwarf2_evaluate_loc_desc is already using this easier to read conditional:
  if (size == 0)
which means:
  if (dlbaton->size == 0)


Thanks,
Jan


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]