This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [rfa/doco] FRAME_FP -> read_fp


Really old thread:

Eli, I'm dropping this patch.  Instead, I'm doing the full rewrite.

Andrew

Date: Wed, 20 Nov 2002 11:25:43 -0500
From: Andrew Cagney <ac131313@redhat.com>

> > Ahm, what does this mean, exactly, "read_fp in the machine description"? > Isn't read_fp a function? If so, how can it be present ``in the machine > description''?


regcache.c contains:

CORE_ADDR
read_fp (void)
{
return TARGET_READ_FP ();
}

and TARGET_READ_FP() is part of the machine description (a.k.a. architecture vector).

Yes, but still I find it confusing to tell that a function is in the
machine description.  A machine description is a bunch of macros and
machine-specific functions, right?  And read_fp is neither of these,
right?


Hmm, I guess this could do with a similar s/FP_REGNUM/read_fp/ transformation?

Probably.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]