This is the mail archive of the
mailing list for the elfutils project.
Re: [patch v6 4/5] x86* unwinder: src/
- From: Mark Wielaard <mjw at redhat dot com>
- To: elfutils-devel at lists dot fedorahosted dot org
- Date: Wed, 30 Oct 2013 17:05:18 +0100
- Subject: Re: [patch v6 4/5] x86* unwinder: src/
On Wed, 2013-10-30 at 16:25 +0100, Jan Kratochvil wrote:
> On Wed, 30 Oct 2013 15:47:06 +0100, Mark Wielaard wrote:
> > I do want as much information as we can give. But IMHO the default
> > should be as basic as possible. Lets do introduce a -v flag (or some
> > others for symbol name demangling, module names, source/line, function
> > arguments, etc.). But not right now. Lets first get the basic
> > functionality in. I am very eager to finally see this committed!
> Modifying the default output in released package is not good.
> So introduced the "-v" flag now.
Sorry, I should have been clearer.
I don't mind the - 1 in the default output as it was.
I meant that "other extras" should go under some future --verbose flag.
That said, I also don't mind how you did it now. At least now we have a
--verbose flag that we can add more stuff under. The change looks good.