This is the mail archive of the
mailing list for the elfutils project.
Re: [PATCH] libdw: Detect dwarf_formudata errors in dwarf_getmacros.
- From: Mark Wielaard <mjw at redhat dot com>
- To: elfutils-devel at lists dot fedorahosted dot org
- Date: Fri, 19 Jun 2015 12:23:26 +0200
- Subject: Re: [PATCH] libdw: Detect dwarf_formudata errors in dwarf_getmacros.
On Thu, 2015-06-18 at 11:21 -0700, Roland McGrath wrote:
> Nested if gets hard to read fast. I usually prefer either && or braces
> around the inner if. But it's fine as is.
I left it as is because it is a simple test/return NULL in this case.
But agreed in general.