This is the mail archive of the
mailing list for the elfutils project.
Re: [patch 1/2] Rename COMPAT_VERSION to COMPAT_VERSION_SAMEPROTO
- From: Mark Wielaard <mjw at redhat dot com>
- To: elfutils-devel at lists dot fedorahosted dot org
- Date: Wed, 01 May 2013 11:52:42 +0200
- Subject: Re: [patch 1/2] Rename COMPAT_VERSION to COMPAT_VERSION_SAMEPROTO
On Wed, 2013-05-01 at 11:25 +0200, Jan Kratochvil wrote:
> > Wouldn't the new definition just work always?
> Yes but it will no longer sanity check the two implementations have the same
> prototype. Which may be useful in many (most?) use cases of it.
> > (I still don't fully understand that last asm bit).
> info '(gcc)Asm Labels'
> IIUC there was an intention that someone cannot call the
> compatibility-only-variant by accident (as one cannot call a function from
> C containing '.' dot). Sure even the caller could use the asm label to call
> this '_compat.ELFUTILS_0.122.dwfl_report_elf' function but if the caller knows
> how to use the asm label s/he should know it is not right to call this one.
Looks good to me. I think you should check it in unless Roland has some
comments on it.