This is the mail archive of the
mailing list for the elfutils project.
Re: [PATCH] libdw: Add new functions dwarf_getlocation_attr and dwarf_getlocation_die.
- From: Jan Kratochvil <jan dot kratochvil at redhat dot com>
- To: elfutils-devel at lists dot fedorahosted dot org
- Date: Wed, 04 Sep 2013 14:23:21 +0200
- Subject: Re: [PATCH] libdw: Add new functions dwarf_getlocation_attr and dwarf_getlocation_die.
On Tue, 03 Sep 2013 14:17:28 +0200, Mark Wielaard wrote:
> Yes, I think we should encourage people to use the more generic
> functions from now on. But no, I don't think actually removing them from
> the libdw.h header is a good idea. IMHO we shouldn't force people to
> rewrite their code if they were using the old functions already (even if
> we can do it in a binary compatible way). It is just that in new code
> one can use the new functions generically.
So one should move those two old functions to the ports branch? They have no
meaning for new code in trunk, they are there only for backward compatibility
with legacy code.
Or do you think anyone would prefer the API of those new functions?
(Maybe so, not sure.)
BTW I do not mind and you are the maintainer IIUC, it was just such an idea.
> And it still is useless without using the function. I don't think it is
> reasonable for a user to depend on the value of number2 in these cases.