This is the mail archive of the
mailing list for the elfutils project.
Re: [PATCH] libdwfl: Correct nested asprintf result check in report_kernel_archive.
- From: Roland McGrath <roland at hack dot frob dot com>
- To: elfutils-devel at lists dot fedorahosted dot org
- Date: Fri, 20 Dec 2013 15:09:28 -0800
- Subject: Re: [PATCH] libdwfl: Correct nested asprintf result check in report_kernel_archive.
Personally I'd like it better as a ?: in the initializer rather than an if
(no repetition of "res ="). But I agree that putting the unlikely (... < 0)
separate from the ... makes it easier to follow.