This is the mail archive of the elfutils-devel@sourceware.org mailing list for the elfutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: unknown error after dwarf_cfi_addrframe()


Does it work at all if you use the standard RH installed version of elfutils?

-ben


> On Feb 12, 2019, at 9:57 AM, Sasha Da Rocha Pinheiro <darochapinhe@wisc.edu> wrote:
> 
> Not working even after adding the directory to libebl_*.so to LD_LIBRARY_PATH. 
> default_abi_cfi is still called returning -1.
> 
> Sasha
> 
> 
> 
> From: Mark Wielaard <mark@klomp.org>
> Sent: Tuesday, February 12, 2019 2:09 AM
> To: Sasha Da Rocha Pinheiro
> Cc: elfutils-devel@sourceware.org; Ben Woodard
> Subject: Re: unknown error after dwarf_cfi_addrframe()
>  
> On Tue, Feb 12, 2019 at 07:25:28AM +0000, Sasha Da Rocha Pinheiro wrote:
>> Oh this is a whole new thing. How have this worked before without those .so? After downloading and compiling elfutils we only copy libdw and libelf.
> 
> The backends are only used for architecture specific ELF things.
> Most of DWARF can be understood in an architecture independent way.
> But CFI does have some arch specific things.
> 
> You should really use make install to get a proper installation,
> not just copy some files. Otherwise you might indeed miss the
> backends, or translations, etc.
> 
> Cheers,
> 
> Mark


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]