This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Setting up Apache2 with mod_perl and Apache2::AuthCookieLDAP

First off, David Habermann, you really should respond to the list instead of emailing me directly so that others can benefit. Dave wrote:

>If you are using a Cygwin based Apache then it will follow symlinks=20
>whereas my experience with the Windows based Apache it doesn't.

Although not a popular opinion, I agree with you.  Cygwin based Apache works
and has a number of desirable properties.

>> However I had set up Apache2 as a Windows service before so I know it's
>> doable. I just forget how to do it! ;-) I thought it was just to specify
>> -k or perhaps -DNO_DETACH or something like that...

I just went through the configs and it (httpd2-config) asked if I wanted to=
 create a service,
I said yes and was all set.=20=20
/bin/cygserver-config (cygserver is apparently required)

Hope this helped.

Yes it did! It's been a long time and in the meantime somebody made /usr/sbin/httpd2-config which sets up the service nicely.

On 5/7/2014 12:13 PM, Andrew DeFaria wrote:
On 5/7/2014 6:23 AM, Andrey Repin wrote:
Goal: Set up Apache2 on my Windows laptop with mod_perl working as well
as Apache2::AuthCookieLDAP and write an example login page that
authenticates to Active Directory using AuthCookieLDAP.

Little bit OT: Is this necessary to set up Cygwin Apache/Perl?

I view my development environment as "Linux". When I don't have bona
fide Linux at my fingertips and they shove a Windows box under my
keyboard I rely on Cygwin to provide a "Linux-like" environment. True
it's not strictly "necessary" to set up a Cygwin Apache/Perl but it is
what I'm best familiar and comfortable with.

First problem (minor): I can't figure out how to install Apache2 as a
Windows service. For now I can just do apachectl2 start but would like
to configure it as a real service. I've tried:

Adefaria-lt:cygrunsrv -I httpd2 -d 'CYGWIN Apache2' -p
/usr/sbin/httpd2.exe -a '-DNO_DETACH'
Adefaria-lt:net start httpd2
The CYGWIN Apache2 service is starting.
The CYGWIN Apache2 service could not be started.

The service did not report an error.

What's in Apache logs?


Let me restate. The problem is there are too many log files! There's /var/log/apache2/[error|access]_log (which shows nothing) and /var/log/apache2.log (which also shows nothing) but then there's /var/log/httpd2.log which shows:

Syntax error on line 172 of /etc/apache2/httpd.conf:
DocumentRoot must be a directory

My DocumentRoot was "/cygdrive/a/web" because I mound my home directory from a NetApp (I believe) to my (unused) A drive. I assure you that "web" is a directory in my home directory. I've also tried the following but all failed:

DocumentRoot "a:/web"
DocumentRoot "//<server>/<share>/adefaria/web"
DocumentRoot "/home/adefaria/web" # where /home/adefaria is a symlink A:

Then I created a local /web directory and moved stuff there and restarted. Now in the error_log I see:

[Wed May 07 12:49:48 2014] [error] (28)No space left on device: Cannot create SSLMutex Configuration Failed

My disks are not full. The only reference I see to this is which doesn't point to an eventual answer. Other googling talks only about Linux systems and how to remove semaphores but none of the semaphores are owned by the Apache user. Used ipcrm -s <semid> to remove all of them. Now Apache starts!
Andrew DeFaria

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]