This is the mail archive of the
mailing list for the binutils project.
RE: [RFC][MIPS] What to do about DT_MIPS_RLD_MAP and PIE
- From: "Maciej W. Rozycki" <macro at codesourcery dot com>
- To: Matthew Fortune <Matthew dot Fortune at imgtec dot com>
- Cc: Richard Sandiford <rdsandiford at googlemail dot com>, "binutils at sourceware dot org" <binutils at sourceware dot org>, "libc-alpha at sourceware dot org" <libc-alpha at sourceware dot org>, "Joseph Myers (joseph at codesourcery dot com)" <joseph at codesourcery dot com>, "Moore, Catherine (Catherine_Moore at mentor dot com)" <Catherine_Moore at mentor dot com>, Nikola Veljkovic <Nikola dot Veljkovic at imgtec dot com>
- Date: Thu, 30 Oct 2014 18:46:21 +0000
- Subject: RE: [RFC][MIPS] What to do about DT_MIPS_RLD_MAP and PIE
- Authentication-results: sourceware.org; auth=none
- References: <6D39441BF12EF246A7ABCE6654B0235320F3027E at LEMAIL01 dot le dot imgtec dot org> <alpine dot DEB dot 1 dot 10 dot 1410221755430 dot 7896 at tp dot orcam dot me dot uk> <6D39441BF12EF246A7ABCE6654B0235320F30462 at LEMAIL01 dot le dot imgtec dot org> <871tpy37ir dot fsf at googlemail dot com> <6D39441BF12EF246A7ABCE6654B0235320F385FA at LEMAIL01 dot le dot imgtec dot org>
On Thu, 30 Oct 2014, Matthew Fortune wrote:
> OK, let's go with that. Time to decide on a name. How about
> DT_MIPS_RLD_MAP_PIE? Long but potentially accurate. We are going to have to
> drag around DT_MIPS_RLD_MAP forever I believe so I suggest we focus the
> new name on the scenario where it is required.
As noted in the other e-mail I suggest using it everywhere, for
uniformity, and I think using the old name for the new assignment should
provide maximum compatibility. We could rename the old assignment to
Can you think of a scenario where it would not work?
Alternatively, we could cook up a generic DT_GNU_RLD_MAP tag for
platforms that want to opt in to a read-only dynamic section/segment and
start using it with the MIPS target first. I think I like the latter a
bit better, any thoughts, anyone?