This is the mail archive of the
mailing list for the binutils project.
Re: [gold patch] Add timers for each pass
> I don't think we should call them pass 1, pass 2, and pass 3. ?That
> implies that the linker is making a pass over the files, which is true
> for passes 1 and 3 but is not true for pass 3. ?Suppose we just say
> "initial tasks run time", "middle tasks run time" and "final tasks run
> time" which corresponds to the names in the code. ?Or if you want to
> come up with more descriptive names that is also OK with me.
Those sound descriptive enough to me (more so than "1", "2", and "3"). Done.
>> ?#ifndef GOLD_TIMER_H
>> ?#define GOLD_TIMER_H
>> +#include <vector>
> No need to #include <vector> here.
Done. (I started out with a vector of "lap times", but decided a
simple array was sufficient.)
> This is OK with those changes.