This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Improve string benchtests

On 05/02/2019 13:17, Wilco Dijkstra wrote:
> Hi Adhemerval,
>> Space after cast.  As a side note, this won't evaluate wstpcpy as-is, since it
>> will use an optimized version and it will result in a wrong generic name for
>> wcscpy.
> I'll have a look at that. Maybe we could create GENERIC_STPCPY from
> concatenation of the STPCPY define. I want to avoid huge amounts of defines
> leading to completely incomprehensible magic.
>> And as a following cleanup for wcpcpy we can use the similar code for strcpy
>> adjusting for wide-chars:
> Sure, there are lots of generic string functions which aren't optimized yet. However
> that's a different patch... This patch simply makes it easy to find those cases.

The idea was not make is a pre-requisite, but rather an idea for a different
patch indeed.

>> Same as before for wcpncpy: instead of reimplement the generic implementation
>> on benchtests we can just include them. And it also leads to an possible
>> optimization on generic implementation for wcpncpy.
> The point is to enable useful comparisons of string implementations. If we include
> the generic implementation then we just compare the generic implementation with
> itself in many cases. And that isn't useful. If I change a generic implementation I
> want to see the difference that makes in the benchmark comparison rather than
> showing no difference.

My understanding is we have the generic implementation as the baseline
where arch-specific optimization might be applied and the idea of the 
comparison is to check against it.  I see no point in using a different 
implementation on benchtests, it should compare against exactly what 
glibc is currently providing.

If you want to check if the your changes improves the generic, you can
compare against multiples glibc builds.

> Maybe the name generic_xxx is confusing? It's meant to be the baseline,
> something which you should beat in all cases with the actual implementation.

My understanding is the baseline should be the generic implementation which
is selected if the architecture does not provide an optimized one.

> Cheers,
> Wilco

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]