This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Requiring Linux 3.2 for glibc 2.24

On Mon, Feb 01, 2016 at 04:46:14PM +0000, Joseph Myers wrote:
> On Mon, 1 Feb 2016, Dmitry V. Levin wrote:
> > On Sun, Jan 31, 2016 at 04:22:07PM +0000, Joseph Myers wrote:
> > > As Linux 2.6.32 has been announced to reach end-of-line next month 
> > > <>, I propose that for glibc 2.24 we 
> > > require Linux 3.2 as the minimum kernel version when glibc is used on 
> > > systems with the Linux kernel and there isn't already a more recent 
> > > architecture-specific minimum.
> > 
> > There are other providers of LTS linux kernels available, for example,
> > RHEL6 kernel has EOL in 2019.  The change you propose would be especially
> > nasty to projects like they provide RHEL based kernels to run
> > containers, and their RHEL7 based openvz kernel is still in testing.
> > Raising the bar in glibc would leave openvz users without a stable kernel
> > where they would be able to run containers based on glibc > 2.23.
> We discussed the containers issue when moving to 2.6.32.  See the thread 
> starting at <> 
> (general idea of not supporting kernels not maintained upstream in 
> <>).  The view 
> was expressed then that it was good to put pressure on such hosting 
> providers to fix outdated kernels 
> <>.  Note that 
> by the time 2.24 is released, 2.6.32 will have been unmaintained at 
> for six months (and 3.2 will be the oldest maintained kernel, 
> which is the basis on which I don't see 2.6.33 as relevant).

That discussion shows that there is no consensus of not supporting kernels
not maintained at, and rightly so, because other stable kernels
maintained by providers are widely in use.

While 2.6.32 at is certainly outdated, 2.6.32 at is
the most recent stable openvz kernel available at this moment, so one
hardly can call it outdated.
In this aspect, the situation is quite different from the previous case
when the bar was raised to 2.6.32, because the latest stable openvz kernel
at that moment also had version 2.6.32.

There are no doubts that raising minimal kernel version to a value greater
than 2.6.32 on x86/x86_64 will make openvz users unhappy, forcing them
to use unstable kernels.


Attachment: pgpyzdquDOeqh.pgp
Description: PGP signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]