This is the mail archive of the
libc-alpha@sourceware.org
mailing list for the glibc project.
Re: PATCH: Add LP_SIZE, OP_LP, ASM_ADDR and RXX_LP to x86_64/sysdep.h
- From: Roland McGrath <roland at hack dot frob dot com>
- To: "H.J. Lu" <hjl dot tools at gmail dot com>
- Cc: GNU C Library <libc-alpha at sourceware dot org>
- Date: Fri, 16 Mar 2012 16:03:09 -0700 (PDT)
- Subject: Re: PATCH: Add LP_SIZE, OP_LP, ASM_ADDR and RXX_LP to x86_64/sysdep.h
- References: <20120316223714.GA1660@intel.com>
It's hard to evaluate the wisdom of particular macro choices without
seeing all the cases where they're used.
Instead of the several MOVE_LP et al, we could just have a single macro:
#define LP(insn) insn##q
(could be a different name). For parity, it seems appropriate to define
that for !__ASSEMBLER__ too, in case they are needed in asm().
Thanks,
Roland