This is the mail archive of the
mailing list for the glibc project.
Re: gcc 3.2 needed for everything?
- From: Roland McGrath <roland at redhat dot com>
- To: Mauricio Silveira <msilveira at linuxbr dot com>
- Cc: libc-alpha at sources dot redhat dot com
- Date: Fri, 11 Oct 2002 22:22:57 -0700
- Subject: Re: gcc 3.2 needed for everything?
> I'd like to know: The gcc >= 3.2 requirement applies for everything
> compiled against glibc-2.3x, or if only glibc-2.3x requires that version
> of gcc for compilation, and gcc 2.9.x still works linking programs
> against glibc-2.3x?? Or am i confusing everything?
This requirement is only for compiling libc itself. The libc header files
should be compatible with any reasonable compiler, certainly any one that
worked with 2.2.5.
Earlier gcc versions have more bugs and we don't recommend using them.
But as far as I know nothing prevents it. However, you should be aware
that there has been little testing at best of using older compilers with
glibc-2.3 headers installed.