This is the mail archive of the
mailing list for the GDB project.
Re: [lttng-dev] Request change name of function lookup_enum in libbabeltrace to make GDB use this lib
* Pedro Alves (email@example.com) wrote:
> On 12/06/2012 03:57 PM, Pedro Alves wrote:
> > On 12/05/2012 12:08 PM, Mathieu Desnoyers wrote:
> >> * Hui Zhu (firstname.lastname@example.org) wrote:
> >>> Hi,
> >>> I am working on add CTF support to GDB. You can see my patch review threads in:
> >>> http://sourceware.org/ml/gdb-patches/2012-11/msg00552.html
> >>> http://sourceware.org/ml/gdb-patches/2012-11/msg00554.html
> >>> http://sourceware.org/ml/gdb-patches/2012-11/msg00553.html
> >>> http://sourceware.org/ml/gdb-patches/2012-11/msg00555.html
> >>> http://sourceware.org/ml/gdb-patches/2012-11/msg00556.html
> >>> To make GDB support CTF read, I use libbabeltrace with GDB. You can
> >>> see the patch in
> >>> http://sourceware.org/ml/gdb-patches/2012-11/msg00555.html.
> >>> I have a issue is libbabeltrace have a function called lookup_enum
> >>> that is same with a GDB function.
> >>> I change the function name of GDB to handle this issue in my patch.
> >>> But Tom said let libbabeltrace to change function name is better.
> >>> So I send this mail to ask do you mind change the function name of
> >>> lookup_enum? If you can change the function name that will be really
> >>> helpful for us. Thanks a lot.
> >>> And I post a patch about change the function name in libbabeltrace.
> >> I'm CCing Julien Desfossez on this one. From what I see,
> >> include/babeltrace/types.h is not included into the system, so it should
> >> not be considered to be a public header of libbabeltrace.
> > I've just built and installed babeltrace 1.0.0 (where's the mainline repository,
> > BTW?), and indeed, I'm not seeing the types.h file anywhere in the
> > installed tree:
> (found mainline at http://www.efficios.com/babeltrace)
> I installed mainline, and quickly skimmed the headers. It seems most of the
> symbols are already namespace clean, using bt_ or babeltrace_ as prefix,
> but I did spot some problems:
> struct bt_context;
> struct stream_pos;
> struct bt_ctf_event;
Good catch. Yes this one is installed.
> struct definition;
> struct declaration;
> struct bt_ctf_event;
> struct bt_ctf_event_decl;
> struct bt_ctf_field_decl;
> It'd be very good if those (and any others I might have missed) were bt_ prefixed too.
Indeed. Julien, can you review all those public headers and ensure they
are correctly namespaced ?
> Pedro Alves
Operating System Efficiency R&D Consultant