This is the mail archive of the
mailing list for the GDB project.
Re: [lttng-dev] Request change name of function lookup_enum in libbabeltrace to make GDB use this lib
- From: Pedro Alves <palves at redhat dot com>
- To: Pedro Alves <palves at redhat dot com>
- Cc: Mathieu Desnoyers <mathieu dot desnoyers at efficios dot com>, Hui Zhu <teawater at gmail dot com>, Julien Desfossez <jdesfossez at efficios dot com>, lttng-dev <lttng-dev at lists dot lttng dot org>, Tom Tromey <tromey at redhat dot com>, gdb at sourceware dot org
- Date: Thu, 06 Dec 2012 16:20:17 +0000
- Subject: Re: [lttng-dev] Request change name of function lookup_enum in libbabeltrace to make GDB use this lib
- References: <CANFwon2s-eJoCrhzJmxhoGx9G2NeOAFf-FDFk1SoxD1OhPxWsg@mail.gmail.com> <20121205120845.GA31696@Krystal> <50C0C06A.firstname.lastname@example.org>
On 12/06/2012 03:57 PM, Pedro Alves wrote:
> On 12/05/2012 12:08 PM, Mathieu Desnoyers wrote:
>> * Hui Zhu (email@example.com) wrote:
>>> I am working on add CTF support to GDB. You can see my patch review threads in:
>>> To make GDB support CTF read, I use libbabeltrace with GDB. You can
>>> see the patch in
>>> I have a issue is libbabeltrace have a function called lookup_enum
>>> that is same with a GDB function.
>>> I change the function name of GDB to handle this issue in my patch.
>>> But Tom said let libbabeltrace to change function name is better.
>>> So I send this mail to ask do you mind change the function name of
>>> lookup_enum? If you can change the function name that will be really
>>> helpful for us. Thanks a lot.
>>> And I post a patch about change the function name in libbabeltrace.
>> I'm CCing Julien Desfossez on this one. From what I see,
>> include/babeltrace/types.h is not included into the system, so it should
>> not be considered to be a public header of libbabeltrace.
> I've just built and installed babeltrace 1.0.0 (where's the mainline repository,
> BTW?), and indeed, I'm not seeing the types.h file anywhere in the
> installed tree:
(found mainline at http://www.efficios.com/babeltrace)
I installed mainline, and quickly skimmed the headers. It seems most of the
symbols are already namespace clean, using bt_ or babeltrace_ as prefix,
but I did spot some problems:
It'd be very good if those (and any others I might have missed) were bt_ prefixed too.