This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Request change name of function lookup_enum in libbabeltrace to make GDB use this lib

On 12/06/2012 10:51 AM, John Gilmore wrote:
> I suggest that it's best if both GDB and Libbabeltrace change the name
> of lookup_enum.  That way you'll be able to compile any version of GDB
> with any version of libbabeltrace (fixed or unfixed) and all four
> combinations will work except "unfixed GDB" and "unfixed
> libbabeltrace").
> If you just change it in the library, gdb stops building on machines that
> have the old library.
> If you just change it in GDB, older gdb's won't be compatible with
> newer libraries.  Hmm, but older gdb's don't link with that library
> anyway.  So you might as well just fix it in GDB; that works for all
> cases.

AFAICS, this is a pretty new library.  It isn't even packaged in Fedora
for example.  And this is new functionality.  There's no need to rush this out.

Libraries should be good citizens and put their external visible symbols in
a namespace, which in C amounts to prefixing their symbols with ctf_ or
whatever.  We should not consider adjusting GDB until we're shure upstream
babeltrace has fully addressed the issue (which it seems it will).  Then the
question at that point becomes one of considering whether we want to support
building with the old broken versions or just forget them.

Pedro Alves

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]