This is the mail archive of the
mailing list for the GDB project.
Re: [rfc] "reset" / "create-inferior" commands
- From: Andrew STUBBS <andrew dot stubbs at st dot com>
- To: gdb at sourceware dot org
- Date: Thu, 02 Nov 2006 11:52:35 +0000
- Subject: Re: [rfc] "reset" / "create-inferior" commands
- References: <20061101202811.GA20484@nevyn.them.org>
Daniel Jacobowitz wrote:
[I would actually have picked "restart" over "reset", but that's taken for
checkpoints. We could still steal it and use "restart checkpoint 1" for
checkpoints, if others think restart is preferable to reset.]
If the initial state is (or can be) considered a special checkpoint then
this is what it should be.
Otherwise the concepts, and therefore commands, should not be confused.
Another possible name I haven't seen yet is 'launch'.