This is the mail archive of the
mailing list for the GDB project.
Re: inferior_pid's magic value of zero.
- To: Todd Whitesel <toddpw at windriver dot com>
- Subject: Re: inferior_pid's magic value of zero.
- From: Fernando Nasser <fnasser at redhat dot com>
- Date: Sun, 25 Mar 2001 11:46:11 -0500
- CC: GDB Developers <gdb at sourceware dot cygnus dot com>
- Organization: Red Hat Canada
- References: <200103250917.BAA01899@alabama.wrs.com>
Todd Whitesel wrote:
> Would anyone object to patches that used a macro (say, NO_INFERIOR) instead
> of the magic 0 that is currently used ?
> Assuming the answer is yes, presumably we'd put the default #define to 0 in
> inferior.h, and allow it to be overridden by tm.h.
What about a multi-arch NO_INFERIOR that can be defined as a function in
you *-tdep code?
The default would be (iferior_pid == 0)
Red Hat Canada Ltd. E-Mail: email@example.com
2323 Yonge Street, Suite #300
Toronto, Ontario M4P 2C9