This is the mail archive of the
gdb-patches@sourceware.org
mailing list for the GDB project.
Re: [PATCH v2 3/8] Add support for non-contiguous blocks to find_pc_partial_function
On Tue, 21 Aug 2018 11:56:52 -0400
Simon Marchi <simon.marchi@ericsson.com> wrote:
> As I mentioned previously, cache_pc_function_{low,high} could be renamed
> to reflect that they now represent the low/high addresses of the range.
> If you think it's not necessary, it's also fine, but I just want to make
> sure the comment didn't just fall through the cracks.
Once I realized that find_pc_partial_function no longer needed to
track both the minimum/maximum function addresses AND the range in
which PC is found, I decided to leave the name alone. (We only track
the latter now.) For a while, I had rewritten it as you had suggested
in your earlier review. It definitely made sense to do this when
find_pc_partial_function returned values for *ADDRESS and *ENDADDR
which referred to the min/max addresses of the function.
I'll take another look at it though. If I decide to leave these names
unchanged, I'll extend the comment in the declaration for
cache_pc_function_{low,high}.
Kevin